<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
    <head>
        <meta charset="UTF-8" />
        <meta http-equiv="X-UA-Compatible" content="IE=edge">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <title>No, PGP is not broken, not even with the Efail vulnerabilities - ProtonMail Blog</title>
    	<link rel="profile" href="http://gmpg.org/xfn/11" />
        <link rel="pingback" href="https://protonmail.com/blog/xmlrpc.php" />
	<link rel="apple-touch-icon" href="/apple-touch-icon.png">
        
<!-- This site is optimized with the Yoast SEO plugin v6.2 - https://yoa.st/1yg?utm_content=6.2 -->
<link rel="canonical" href="https://protonmail.com/blog/pgp-vulnerability-efail/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="No, PGP is not broken, not even with the Efail vulnerabilities - ProtonMail Blog" />
<meta property="og:description" content="Recently, news broke about potential vulnerabilities in PGP, dubbed Efail. However, despite reports to the contrary, PGP is not actually broken, as we will explain in this post. The vulnerability report, which came with its own website, efail.de, has attracted a lot of headlines such as the one below, along with recommendations to disable the &hellip;" />
<meta property="og:url" content="https://protonmail.com/blog/pgp-vulnerability-efail/" />
<meta property="og:site_name" content="ProtonMail Blog" />
<meta property="article:tag" content="featured" />
<meta property="article:section" content="Encryption" />
<meta property="article:published_time" content="2018-05-15T02:33:10+02:00" />
<meta property="article:modified_time" content="2018-05-15T12:58:47+02:00" />
<meta property="og:updated_time" content="2018-05-15T12:58:47+02:00" />
<meta property="og:image" content="https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis.jpg" />
<meta property="og:image:secure_url" content="https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="512" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/protonmail.com\/blog\/","name":"ProtonMail Blog","potentialAction":{"@type":"SearchAction","target":"https:\/\/protonmail.com\/blog\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/protonmail.com\/blog\/pgp-vulnerability-efail\/","sameAs":[],"@id":"#organization","name":"ProtonMail","logo":"https:\/\/protonmail.com\/blog\/wp-content\/uploads\/2016\/10\/logo.jpg"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//protonmail.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ProtonMail Blog &raquo; Feed" href="https://protonmail.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="ProtonMail Blog &raquo; Comments Feed" href="https://protonmail.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ProtonMail Blog &raquo; No, PGP is not broken, not even with the Efail vulnerabilities Comments Feed" href="https://protonmail.com/blog/pgp-vulnerability-efail/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/protonmail.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='es-widget-css-css'  href='https://protonmail.com/blog/wp-content/plugins/email-subscribers/widget/es-widget.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='main-style-css'  href='https://protonmail.com/blog/wp-content/themes/bootstrap-basic/css/main.css?ver=4.9.2' type='text/css' media='all' />
<script type='text/javascript' src='https://protonmail.com/blog/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-content/plugins/stop-user-enumeration/frontend/js/frontend.js?ver=1.3.15'></script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-content/themes/bootstrap-basic/js/vendor/modernizr.min.js?ver=3.3.1'></script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-content/themes/bootstrap-basic/js/vendor/html5shiv.min.js?ver=3.7.3'></script>
<link rel='https://api.w.org/' href='https://protonmail.com/blog/wp-json/' />
<meta name="generator" content="WordPress 4.9.2" />
<link rel='shortlink' href='https://protonmail.com/blog/?p=3829' />
<link rel="alternate" type="application/json+oembed" href="https://protonmail.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprotonmail.com%2Fblog%2Fpgp-vulnerability-efail%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://protonmail.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fprotonmail.com%2Fblog%2Fpgp-vulnerability-efail%2F&#038;format=xml" />
<style type="text/css">	.csbtns {
											
											
											
											
										}
										.csbtns img		
										{ 	
											width: 35px !important;
											padding: 6px;
											border:  0;
											box-shadow: none !important;
											display: inline;
											vertical-align: middle;
										}
										.csbtns, .csbtns a		
										{
											text-decoration:none;
											background: none;
											
											font-size: 	20px;
											
											
										}</style><style type="text/css">
ul.scfw_16px li, ul.scfw_24px li, ul.scfw_32px li, ul.scfw_16px li a, ul.scfw_24px li a, ul.scfw_32px li a {
	display:inline !important;
	float:none !important;
	border:0 !important;
	background:transparent none !important;
	margin:0 !important;
	padding:0 !important;
}
ul.scfw_16px li {
	margin:0 2px 0 0 !important;
}
ul.scfw_24px li {
	margin:0 3px 0 0 !important;
}
ul.scfw_32px li {
	margin:0 5px 0 0 !important;
}
ul.scfw_text_img li:before, ul.scfw_16px li:before, ul.scfw_24px li:before, ul.scfw_32px li:before {
	content:none !important;
}
.scfw img {
	float:none !important;
}
</style>	
	<!-- <meta name="vfb" version="2.8.8" /> -->
        <link rel="stylesheet" href="https://protonmail.com/css/theme.css" media="screen" charset="utf-8">
        <style media="screen">
        .content a {
            color: #9497ce;
            text-decoration: underline;
        }
        .content a.btn {
            text-decoration: none;
        }
        .content a:hover {
            color: #000;
        }
        </style>
    </head>
<body class="post-template-default single single-post postid-3829 single-format-standard" itemtype="http://schema.org/WebPage" itemscope="itemscope">

<nav class="navbar navbar-default navbar-inverse navbar-fixed-top" id="header">
    <div class="top hidden-sm hidden-xs">
        <div class="container text-right form-inline">
	    <a class="pull-left" href="/"><i class="fa fa-chevron-left"></i> &nbsp;Return to protonmail.com</a>
            <a target="_blank" href="https://plus.google.com/+protonmail" rel="publisher">
                <i class="fa fa-google"></i> +Google
            </a>
            <a target="_blank" href="https://facebook.com/ProtonMail" title="Facebook">
                <i class="fa fa-facebook"></i> Facebook
            </a>
            <a target="_blank" href="https://twitter.com/ProtonMail" title="Twitter">
                <i class="fa fa-twitter"></i> Twitter
            </a>
        </div>
    </div>
    <div class="bottom">
        <div class="container">
            <!-- Brand and toggle get grouped for better mobile display -->
            <div class="navbar-header">
                <a href="#" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1" aria-expanded="false">
                    <span class="sr-only">Toggle navigation</span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                    <span class="icon-bar"></span>
                </a>
                <a class="navbar-brand" href="https://protonmail.com/blog/">
                    <img src="https://protonmail.com/images/logo.png" alt="" height="23" class="pull-left">
                </a>
            </div>

            <!-- Collect the nav links, forms, and other content for toggling -->
            <div class="navbar-collapse collapse" id="bs-example-navbar-collapse-1" aria-expanded="false" style="height: 0px;">
                <ul class="nav navbar-nav navbar-right">
                    <li class="first"><a href="https://protonmail.com/about" title="About">About</a></li>
                    <li><a href="https://protonmail.com/security-details" title="Security">Security</a></li>
                    <li class="active"><a href="https://protonmail.com/blog/" title="Blog">Blog</a></li>
                    <li><a href="https://protonmail.com/careers" title="Careers">Careers</a></li>
                    <li><a href="https://protonmail.com/support/" title="Support">Support</a></li>
                    <li><a href="https://protonmail.com/donate" title="Donate">Donate</a></li>
                    <li><a href="https://mail.protonmail.com/login" title="Log In" class="btn btn-ghost btn-short">LOG IN</a></li>
                    <li><a href="https://protonmail.com/signup" title="Sign Up" class="btn btn-default btn-short">SIGN UP</a></li>
                </ul>
            </div><!-- /.navbar-collapse -->
        </div><!-- /.container-fluid -->
    </div>
</nav>
<div id="header-spacer"></div>

<div class="container content">
<div class="col-lg-10 col-lg-offset-1 content-area" id="main-column">
	<div id="main" class="site-main" role="main">
		
			<div class="bar">
				<div class="row">
					<div class="col-sm-8">


<ul class="hidden-sm hidden-xs">
                                <li class="cat-item"><a href="https://protonmail.com/blog/">All</a></li>
                            	<li class="cat-item cat-item-9"><a href="https://protonmail.com/blog/category/news/" >Articles &amp; News</a>
</li>
	<li class="cat-item cat-item-24"><a href="https://protonmail.com/blog/category/encryption/" >Encryption</a>
</li>
	<li class="cat-item cat-item-25"><a href="https://protonmail.com/blog/category/privacy/" >Privacy</a>
</li>
	<li class="cat-item cat-item-7"><a href="https://protonmail.com/blog/category/release-notes/" >Releases</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://protonmail.com/blog/category/security/" >Security</a>
</li>
                        </ul>
                        <select  name='cat' id='cat' class='form-control hidden-md hidden-lg' >
	<option class="level-0" value="9">Articles &amp; News</option>
	<option class="level-0" value="24">Encryption</option>
	<option class="level-0" value="25">Privacy</option>
	<option class="level-0" value="7">Releases</option>
	<option class="level-0" value="6">Security</option>
</select>

<!--
						<select  name='cat' id='cat' class='form-control' >
	<option class="level-0" value="9">Articles &amp; News</option>
	<option class="level-0" value="24">Encryption</option>
	<option class="level-0" value="25">Privacy</option>
	<option class="level-0" value="7">Releases</option>
	<option class="level-0" value="6">Security</option>
</select>
-->

					</div>
					<div class="col-sm-4 text-right">
						
<a class="btn btn-link" target="_blank" href="https://plus.google.com/share?url=https://protonmail.com/blog/pgp-vulnerability-efail/" rel="publisher">
        <i class="fa fa-google"></i>
</a>
<a class="btn btn-link" target="_blank" href="http://www.facebook.com/sharer.php?u=https://protonmail.com/blog/pgp-vulnerability-efail/" title="Facebook">
        <i class="fa fa-facebook"></i>
</a>
<a class="btn btn-link" target="_blank" href="http://twitter.com/share?text=No, PGP is not broken, not even with the Efail vulnerabilities&url=https://protonmail.com/blog/pgp-vulnerability-efail/" title="Twitter">
        <i class="fa fa-twitter"></i>
</a>
<a class="btn btn-link" target="_blank" href="https://protonmail.com/blog/feed/" title="RSS">
        <i class="fa fa-rss"></i>
</a>
					</div>
				</div>
			</div>

			<article id="post-3829" class="post-3829 post type-post status-publish format-standard has-post-thumbnail hentry category-encryption category-security tag-featured">

	<header class="entry-header">
		<h1 class="entry-title">No, PGP is not broken, not even with the Efail vulnerabilities</h1>

				<div class="entry-meta">
			<span class="posted-on">Posted on <a href="https://protonmail.com/blog/pgp-vulnerability-efail/" title="2:33 AM" rel="bookmark"><time class="entry-date published" datetime="2018-05-15T02:33:10+00:00">May 15, 2018</time><time class="updated" datetime="2018-05-15T12:58:47+00:00">May 15, 2018</time></a></span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://protonmail.com/blog/author/andy/" title="View all posts by Andy Yen">Andy Yen</a></span></span>		</div><!-- .entry-meta -->
		
	</header><!-- .entry-header -->

<div class="post-image">
<img width="1024" height="512" src="https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis.jpg" class="attachment-1200 size-1200 wp-post-image" alt="" thumbnail="" srcset="https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis.jpg 1024w, https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis-300x150.jpg 300w, https://protonmail.com/blog/wp-content/uploads/2018/05/protonmail-efail-technical-analysis-768x384.jpg 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></div>

		<div class="entry-content">
		<h2>Recently, news broke about potential vulnerabilities in PGP, dubbed Efail. However, despite reports to the contrary, PGP is not actually broken, as we will explain in this post.</h2>
<p>The vulnerability report, which came with its own website, <a href="https://efail.de" target="_blank" rel="noopener">efail.de</a>, has attracted a lot of headlines such as the one below, along with recommendations to <a href="https://www.eff.org/deeplinks/2018/05/attention-pgp-users-new-vulnerabilities-require-you-take-action-now" target="_blank" rel="noopener">disable the usage of PGP plugins</a>. This was not helped by the fact that until earlier today, the full details of the “vulnerability” were not disclosed to the community. However, now that the information is public and we have completed our analysis, we can say that <strong>these headlines are wrong</strong>, and recommendations to stop using PGP plugins are misguided. We have published our own recommendations below as well.</p>
<p><a href="https://protonmail.com/blog/wp-content/uploads/2018/05/pgp-headline.jpg"><img class="aligncenter wp-image-3830" src="https://protonmail.com/blog/wp-content/uploads/2018/05/pgp-headline.jpg" alt="pgp-vulnerability" width="500" height="325" srcset="https://protonmail.com/blog/wp-content/uploads/2018/05/pgp-headline.jpg 938w, https://protonmail.com/blog/wp-content/uploads/2018/05/pgp-headline-300x195.jpg 300w, https://protonmail.com/blog/wp-content/uploads/2018/05/pgp-headline-768x499.jpg 768w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p><strong>First, ProtonMail is not impacted by the Efail PGP vulnerabilities.</strong> This includes our web and mobile applications, and also our <a href="https://protonmail.com/bridge" target="_blank" rel="noopener">ProtonMail Bridge</a> software for desktop. In the second part of this post, we have included a full technical analysis explaining why ProtonMail is not vulnerable.</p>
<p><strong>It is equally important to state that, other than one minor exception (discussed later), Efail is not a vulnerability in PGP itself.</strong> What the authors of Efail did was catalogue a list of PGP clients that have errors in their PGP implementation. In the worst case, these implementation flaws can lead to encrypted emails being decrypted, provided the attackers already have a copy of your encrypted email and the capability to resend it to you (both are pretty strong caveats that dramatically limit the scope of the vulnerability).</p>
<h3>PGP Security and Efail</h3>
<p>PGP has a long history, dating back over 20 years, and while some may use this to claim that PGP is “outdated” or “unfashionable”, it also means that PGP is time and battle-tested. Simply put, it is the best way to encrypt emails, and because the protocol is open, it has had over two decades of peer review and security audits. This means it is very unlikely to have undiscovered vulnerabilities lurking under the hood.</p>
<p>However, in cryptography, as in many things, the devil is in the details, and implementing PGP securely is indeed a challenge. Many of the PGP software libraries and plugins have not undergone the same level of scrutiny as the OpenPGP protocol itself. Indeed, some of the vulnerabilities disclosed in Efail have been <a href="https://lists.gnupg.org/pipermail/gnupg-users/2018-May/060334.html" target="_blank" rel="noopener">known to the PGP developer community since 1999</a> and some PGP plugins remain vulnerable.</p>
<p>As an open standard, anybody can implement PGP, and some do it better than others, so it should come as no surprise that some PGP implementations have security vulnerabilities. However, this should not be taken to be an indictment of PGP.<strong> At its core, PGP remains cryptographically sound</strong>, and using a few bad implementations to claim that “PGP has a serious flaw” is both untrue and disingenuous.</p>
<h3>Recommendations for PGP users</h3>
<p><strong>Recommendations to disable PGP plugins and stop encrypting emails are completely unwarranted and could put lives at risk.</strong> The correct response to vulnerable PGP implementations should not be to stop using PGP, but to use secure PGP implementations. If a vulnerability is discovered in your operating system, you don’t throw away your computer. Instead, you update it and patch it. When it comes to vulnerabilities in PGP implementations, the same principle applies. If you are a PGP user, we recommend the same strategy. <strong>Apply updates to your PGP software when they become available</strong> (if necessary). Because the vulnerabilities are in the PGP implementations and not the OpenPGP protocol itself, these bugs are very easy for PGP plugin developers to patch. <strong>Or you can switch to <a href="https://protonmail.com" target="_blank" rel="noopener">using ProtonMail</a> which is not susceptible to the Efail vulnerabilities.</strong></p>
<h3>ProtonMail is not impacted by the Efail PGP vulnerabilities</h3>
<p>In this section, we will provide a technical analysis of why ProtonMail is not impacted by the PGP implementation vulnerabilities disclosed in the Efail paper. Due to the subject matter, the discussion is necessarily technical in nature. At the end, we also discuss our views on the future of PGP.</p>
<p>There are three distinct attacks <a href="https://efail.de/efail-attack-paper.pdf" target="_blank" rel="noopener">presented in the paper</a> &#8211; a direct exfiltration attack, an attack on S/MIME, and an attack on OpenPGP. We have analyzed the first and third for any potential vulnerabilities, as ProtonMail does not use or support S/MIME. We will note, however, that S/MIME is actually the more serious vulnerability because it is widely used by government and military and may be unfixable, so the media’s fixation on PGP is misplaced since PGP itself is not actually broken.</p>
<p><strong>Direct Exfiltration Channel Attack</strong></p>
<p>The first attack presented in the paper is the “direct exfiltration channel” attack, in which an adversary constructs an email structure where a plaintext part with an &lt;img&gt; element is prepended to the ciphertext. Then, when the ciphertext is decrypted by the recipient, it will theoretically be replaced by the corresponding plaintext in the client, and then the client will attempt to parse the image source, sending the plaintext in the HTTP request path.</p>
<p>ProtonMail is not vulnerable to this attack because we do not handle emails containing both plaintext and ciphertext in the way described in the paper. When ProtonMail’s servers parse incoming mail, a message of this structure is treated as a plaintext email and encrypted with the recipient’s public keys before being sent to ProtonMail clients. The only case in which the message is not encrypted by the server before being sent to the client is if the message begins with a valid ASCII-armored PGP message. In this case, the PGP message is used directly and any subsequent plaintext is discarded. This ensures that all emails sent to the clients are encrypted and cannot be a mixture of plaintext and ciphertext.</p>
<p>When a message is opened, the ProtonMail client attempts to decrypt the entire PGP message from the server using the recipient’s private keys. If decryption succeeds and the decrypted content contains any additional encrypted content, the client will never attempt to decrypt this “nested” content. Therefore, an attempted attack of this type would merely result in the encrypted text being sent in the HTTP request path (which, according to the attack parameters, the attacker would have already), and only if the user chose to load remote content, which is always disabled by default. Additionally, because ProtonMail’s clients never do any “nested” decryption, it would be impossible for ProtonMail’s servers to launch this type of attack.</p>
<p><strong>Malleability Gadget Exfiltration Channel Attack</strong></p>
<p>The “malleability gadget exfiltration channel” attack relies on the fact that due to the malleability of Cipher Feedback Mode (CFB), the mode of encryption used by OpenPGP, knowledge of some of a ciphertext’s decrypted content can allow an attacker to inject malicious content into the ciphertext itself.</p>
<p>This attack is circumvented by the use of the Symmetrically Encrypted with Integrity Protection (SEIP) OpenPGP packet for storing encrypted data, which ProtonMail has always used for encrypted emails sent between ProtonMail users, and which is used by the vast majority of modern PGP clients. When data is encrypted with this packet type, the plaintext data that is about to be encrypted is hashed and stored in a Modification Detection Code (MDC) packet. During the decryption process, the decrypted data is hashed and compared with the result stored in the MDC packet. If the results are not equal, this is treated by all of ProtonMail’s OpenPGP libraries as a decryption failure, and clients will not load the decrypted content.</p>
<p>The paper brings up three methods by which integrity protection could be defeated. The first and second, Ignoring the MDC and Stripping the MDC, are not feasible in ProtonMail’s clients because our cryptography libraries would treat these scenarios as decryption failures. The third method is for the attacker to change an SEIP packet into a Symmetrically Encrypted packet, which is an obsolete OpenPGP packet with no modification detection capabilities.</p>
<p>This is the minor exception that we mentioned previously. While this can be construed as a vulnerability in the OpenPGP standard, the solution is easy (drop support for this obsolete packet type). The open-source library used by our web application, OpenPGP.js, is not vulnerable to this attack because it already does not allow the use of Symmetrically Encrypted packets with any AES ciphers, which are the only ciphers supported for symmetric encryption by ProtonMail and most PGP clients. Even without this, ProtonMail users are protected from this attack because ProtonMail servers disallow all OpenPGP packets of the Symmetrically Encrypted type from all mail.</p>
<h3>The Future of PGP</h3>
<p><strong>PGP remains to this day, the best way for encrypting emails, and if implemented properly, is both secure and reliable.</strong> While ProtonMail was not impacted by the recent PGP implementation vulnerabilities, we recognize that as the leaders in this space, we also need to play a part in ensuring that other PGP implementations are also secure. In pursuit of this goal, and as part of our responsibilities as the <a href="https://protonmail.com/blog/openpgpjs-3-release/" target="_blank" rel="noopener">maintainers of OpenPGPjs</a>, we are doing the following:</p>
<p>First, we are dropping support of the obsolete Symmetrically Encrypted packet type when OpenPGPjs is used with default options. As OpenPGPjs is one of the world’s most widely used OpenPGP libraries (powering popular plugins such as <a href="https://www.enigmail.net/index.php/en/" target="_blank" rel="noopener">Enigmail</a>, <a href="https://www.mailvelope.com/en" target="_blank" rel="noopener">Mailvelope</a>, and many others), this will help to protect the PGP ecosystem from Malleability Gadget Exfiltration Channel Attacks in the future.</p>
<p>Secondly, we will continue to push forward Authenticated Encryption. Authenticated encryption with associated data (AEAD) is a form of encryption that provides confidentiality, integrity, and authenticity guarantees on data, evading any attack of the types described in the paper. The Efail paper erroneously claims that “there were efforts to introduce authenticated encryption in OpenPGP which are, however, expired.” This is untrue, as there is currently a <a href="https://tools.ietf.org/html/draft-ietf-openpgp-rfc4880bis-04" target="_blank" rel="noopener">working draft for AEAD support in OpenPGP</a>, which has been gaining significant traction in the security community. We have also recently completed a full implementation of <a href="https://github.com/openpgpjs/openpgpjs/releases/tag/v3.0.9" target="_blank" rel="noopener">AEAD in OpenPGP.js</a> which is currently undergoing a third party security audit.</p>
<p>As the world’s largest secure email provider, we take security very seriously and will continue to innovate to ensure that your data remains secure and private, both today and in the future.</p>
<p>Best Regards,<br />
The ProtonMail Team</p>
<p>For the official statement from the maintainers of GNUPG, another common PGP software, please <a href="https://lists.gnupg.org/pipermail/gnupg-users/2018-May/060334.html" target="_blank" rel="noopener">see here</a>.</p>
<p><em>The above analysis includes contributions from Sanjana Rajan, Bart Butler, Andy Yen, Daniel Huigens and Yanfeng Zhang from the ProtonMail team.</em></p>
<p><em><strong>ProtonMail provides </strong></em><em><strong><a href="https://protonmail.com" target="_blank" rel="noopener">free encrypted email</a> accounts to the public</strong></em><em><strong>.</strong></em></p>
<p><em><strong>We also provide a </strong></em><a href="https://protonvpn.com/"><em><strong>free VPN service</strong></em></a><em><strong> to protect your privacy.</strong></em></p>
<!-- I got these buttons from mrwebsolution.in :) --><div class="csbtns">Share This!<a class="csbtns_google_share" href="https://plus.google.com/share?url=https://protonmail.com/blog/pgp-vulnerability-efail/" target="_blank"><img title="Google+" class="csbtns" alt="Share on Google+" src="https://protonmail.com/blog/wp-content/plugins/custom-share-buttons/buttons/somacro/google.png" /></a><a class="csbtns_reddit_share" href="http://reddit.com/submit?url=https://protonmail.com/blog/pgp-vulnerability-efail/&amp;title=No, PGP is not broken, not even with the Efail vulnerabilities" target="_blank"><img title="Reddit" class="csbtns" alt="Share on Reddit" src="https://protonmail.com/blog/wp-content/plugins/custom-share-buttons/buttons/somacro/reddit.png" /></a><a class="csbtns_facebook_share" href="http://www.facebook.com/sharer.php?u=https://protonmail.com/blog/pgp-vulnerability-efail/" target="_blank"><img title="Facebook" class="csbtns" alt="Share on Facebook" src="https://protonmail.com/blog/wp-content/plugins/custom-share-buttons/buttons/somacro/facebook.png" /></a><a class="csbtns_email_share" href="mailto:?Subject=No, PGP is not broken, not even with the Efail vulnerabilities&amp;Body=%20https://protonmail.com/blog/pgp-vulnerability-efail/"><img title="Email" class="csbtns" alt="Email this to someone" src="https://protonmail.com/blog/wp-content/plugins/custom-share-buttons/buttons/somacro/email.png" /></a><a class="csbtns_twitter_share" href="http://twitter.com/share?url=https://protonmail.com/blog/pgp-vulnerability-efail/&amp;text=No%2C+PGP+is+not+broken%2C+not+even+with+the+Efail+vulnerabilities+" target="_blank"><img title="Twitter" class="csbtns" alt="Tweet about this on Twitter" src="https://protonmail.com/blog/wp-content/plugins/custom-share-buttons/buttons/somacro/twitter.png" /></a><a href="/signup" class="btn btn-primary pull-right" style="font-size:1.5rem">Get a Free Encrypted Email Account</a></div>		<div class="clearfix"></div>
			</div><!-- .entry-content -->
	

	<footer class="entry-meta">
				<div class="entry-meta-category-tag">
						<span class="cat-links">
				<span class="categories-icon glyphicon glyphicon-th-list" title="Posted in"></span> <a href="https://protonmail.com/blog/category/encryption/" rel="category tag">Encryption</a>, <a href="https://protonmail.com/blog/category/security/" rel="category tag">Security</a>			</span>
			
						<span class="tags-links">
				<span class="tags-icon glyphicon glyphicon-tags" title="Tagged"></span>&nbsp; <a href="https://protonmail.com/blog/tag/featured/" rel="tag">featured</a>			</span>
					</div><!--.entry-meta-category-tag-->
		
		<div class="entry-meta-comment-tools">
						<span class="comments-link"><a href="https://protonmail.com/blog/pgp-vulnerability-efail/#comments" class="btn btn-default btn-xs" ><span class="comment-icon glyphicon glyphicon-comment"><small class="comment-total">2</small></span></a></span>
			
			<a class="post-edit-link btn btn-default btn-xs" href="" title="Edit"><i class="edit-post-icon glyphicon glyphicon-pencil" title="Edit"></i></a>		</div><!--.entry-meta-comment-tools-->
	</footer><!-- .entry-meta -->
</article><!-- #post-## -->


			



<p><em>About the Author</em></p>
<div class="author well">
    <div class="row">
      <div class="col-md-2 hidden-sm">
<img src="https://protonmail.com/images/about/andy-yen.jpg" alt="Andy Yen" class="img-circle">
</div>
      <div class="col-md-10 col-sm-12">
        <h4><strong>Andy Yen</strong></h4>
                <p>Andy is a founder of ProtonMail. He is a long time advocate of privacy rights and has spoken at TED, SXSW, and the Asian Investigative Journalism Conference about online privacy issues. Previously, Andy was a research scientist at CERN and has a PhD in Particle Physics from Harvard University. You can watch his TED talk online to learn more about ProtonMail's mission.</p>
      </div>
    </div>
  </div>



			
<p>&nbsp;</p>
			<div id="related-posts">

				<h3>Learn More</h3>

				<div class="row">
					<div class="col-md-6">
					<h5><a href="https://protonmail.com/blog/sesta-fosta-email-privacy/"><strong>Concerned about SESTA-FOSTA? Learn how ProtonMail protects your privacy</strong></a></h5><span class="date"><em>April 18, 2018 in <a href="https://protonmail.com/blog/category/news/">Articles &amp; News</a></em></span><div>Donald Trump signed SESTA-FOSTA into law, a policy ostensibly meant to prevent sexual trafficking. In reality, the law undermines free expression online and may even jeopardize the safety&hellip;</div>					</div>
					<div class="col-md-6">
					<h5><a href="https://protonmail.com/blog/white-house-encryption-protonmail/"><strong>Correcting misconceptions about the White House's use of encryption and ProtonMail</strong></a></h5><span class="date"><em>March 18, 2018 in <a href="https://protonmail.com/blog/category/encryption/">Encryption</a></em></span><div>Like many of you, we have seen the story this weekend where it was revealed that ProtonMail was being used by White House staff. As a matter of&hellip;</div>					</div>
				</div><!--/.row-->

				<div class="row">
					<div class="col-md-6">
					<h5><a href="https://protonmail.com/blog/protonmail-vs-gmail-security/"><strong>Why ProtonMail Is More Secure Than Gmail</strong></a></h5><span class="date"><em>October 22, 2017 in <a href="https://protonmail.com/blog/category/security/">Security</a></em></span><div>ProtonMail is an encrypted email service that takes a radically different approach to email security. Find out how ProtonMail security compares to Gmail security. In 2014, ProtonMail became&hellip;</div>					</div>
					<div class="col-md-6">
					<h5><a href="https://protonmail.com/blog/encrypted_email_authentication/"><strong>Improved Authentication for Email Encryption and Security</strong></a></h5><span class="date"><em>December 1, 2016 in <a href="https://protonmail.com/blog/category/encryption/">Encryption</a></em></span><div>Today, we are happy to announce the launch of a brand new authentication system for ProtonMail's secure email service using just a single password. ProtonMail launched with a&hellip;</div>					</div>
				</div><!--/.row-->

			</div><!--/#related-posts-->

			
			

<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/pgp-vulnerability-efail/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://protonmail.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form form form-horizontal" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span></p><div class="form-group row"><label class="control-label col-md-2" for="comment">Comment</label> <div class="col-md-10"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true" class="form-control"></textarea></div></div><p class="help-block">You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt;</code> <code>&lt;abbr title=&quot;&quot;&gt;</code> <code>&lt;acronym title=&quot;&quot;&gt;</code> <code>&lt;b&gt;</code> <code>&lt;blockquote cite=&quot;&quot;&gt;</code> <code>&lt;cite&gt;</code> <code>&lt;code&gt;</code> <code>&lt;del datetime=&quot;&quot;&gt;</code> <code>&lt;em&gt;</code> <code>&lt;i&gt;</code> <code>&lt;q cite=&quot;&quot;&gt;</code> <code>&lt;s&gt;</code> <code>&lt;strike&gt;</code> <code>&lt;strong&gt; </code> </p><div class="form-group row"><label class="control-label col-md-2" for="author">Name</label> <div class="col-md-10"><input id="author" name="author" type="text" value="" size="30" class="form-control" /></div></div>
<div class="form-group row"><label class="control-label col-md-2" for="email">Email</label> <div class="col-md-10"><input id="email" name="email" type="email" value="" size="30" class="form-control" /></div></div>
<div class="form-group row"><label class="control-label col-md-2" for="url">Website</label> <div class="col-md-10"><input id="url" name="url" type="url" value="" size="30" class="form-control" /></div></div>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="btn btn-primary" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3829' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>		<p class="antispam-group antispam-group-q" style="clear: both;">
			<label>Current ye@r <span class="required">*</span></label>
			<input type="hidden" name="antspm-a" class="antispam-control antispam-control-a" value="2018" />
			<input type="text" name="antspm-q" class="antispam-control antispam-control-q" value="4.4" autocomplete="off" />
		</p>
		<p class="antispam-group antispam-group-e" style="display: none;">
			<label>Leave this field empty</label>
			<input type="text" name="antspm-e-email-url-website" class="antispam-control antispam-control-e" value="" autocomplete="off" />
		</p>
			</form>
			</div><!-- #respond -->
	


        
                        <h3 class="comments-title">
                        2 comments on &ldquo;<span>No, PGP is not broken, not even with the Efail vulnerabilities</span>&rdquo;                </h3>

                
                <ul class="media-list">
                        <li id="comment-16221" class="comment even thread-even depth-1 parent media"><article id="div-comment-16221" class="comment-body media"><footer class="comment-meta pull-left"></footer><!-- .comment-meta --><div class="comment-content media-body"><div class="comment-author vcard"><div class="comment-metadata"><strong><cite class="fn">C. in Dallas</cite></strong>, <a href="https://protonmail.com/blog/pgp-vulnerability-efail/#comment-16221"><time datetime="2018-05-15T03:12:24+00:00">May 15, 2018 at 3:12 AM</time></a> </div><!-- .comment-metadata --></div><!-- .comment-author --><p>Thanks, ProtonMail.  Yes PGP itself is not broken.  It&#8217;s been in use for many years.</p>
<p>Internet privacy is gathering steam.  But are any of us really free when there are hundreds of millions of internet users in China who are still in bondage?  In China, most people have no internet privacy.  The longer this condition continues, the more it will be found acceptable.  Other countries like Iran will try to remove internet freedoms.</p>
<p>If you are in China&#8217;s government, please leak internal documents and plans which show how much China&#8217;s government really hates the thoughts and feelings of Chinese citizens. </p>
<p>Imagine China&#8217;s citizens becoming free.  Leak the documents of the Chinese leadership until all Chinese citizens demand their freedom, and actually become free to use an uncensored internet.</p>
<p>Thank you ProtonMail for being a leader in secure communication.  We need more and more like you.</p>
<a rel='nofollow' class='comment-reply-link btn btn-default btn-sm' href='https://protonmail.com/blog/pgp-vulnerability-efail/?replytocom=16221#respond' onclick='return addComment.moveForm( "div-comment-16221", "16221", "respond", "3829" )' aria-label='Reply to C. in Dallas'><span class="fa fa-reply"></span> Reply</a></div><!-- .comment-content --></article><!-- .comment-body --><ul class="children">
<li id="comment-16222" class="comment odd alt depth-2"><article id="div-comment-16222" class="comment-body media"><footer class="comment-meta pull-left"></footer><!-- .comment-meta --><div class="comment-content media-body"><div class="comment-author vcard"><div class="comment-metadata"><strong><cite class="fn">Carbs</cite></strong>, <a href="https://protonmail.com/blog/pgp-vulnerability-efail/#comment-16222"><time datetime="2018-05-15T05:05:17+00:00">May 15, 2018 at 5:05 AM</time></a> </div><!-- .comment-metadata --></div><!-- .comment-author --><p>ProtonMail is more focussed on the defensive side of cyber security than the offensive. Quite frankly, their only use of offensive measures is probably testing their own products, for vulnerabilities. The people to go to for leaking China&#8217;s documents would, from my inexperienced opinion, be WikiLeaks, since they must be in contact with quite a few capable hackers.</p>
<a rel='nofollow' class='comment-reply-link btn btn-default btn-sm' href='https://protonmail.com/blog/pgp-vulnerability-efail/?replytocom=16222#respond' onclick='return addComment.moveForm( "div-comment-16222", "16222", "respond", "3829" )' aria-label='Reply to Carbs'><span class="fa fa-reply"></span> Reply</a></div><!-- .comment-content --></article><!-- .comment-body --></li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
                </ul><!-- .comment-list -->

                
        

</div><!-- #comments -->



			</div>
</div>
</div><!--/.container-->

<div class="free-email-section">
	<div class="container text-center">
		<h5 class="text-center">Get your secure email account</h5>
		<a href="/signup" class="btn btn-primary btn-lg">Create Account</a>
	</div><!--/.container-->
</div>

<div class="contact-cols">
    <div class="container content">
        <p>Proton Technologies AG</p>
        <div class="row">
            <div class="col-md-3">
                <p>
                    Chemin du Pré-Fleuri, 3 <br>CH-1228 Plan-les-Ouates, Genève, Switzerland
                </p>
            </div><!--/.col-->
            <div class="col-md-3">
                <p>
                    <i class="fa fa-envelope"></i> General: <a href="mailto:contact@protonmail.ch">contact@protonmail.ch</a><br>
                    <i class="fa fa-envelope"></i> Media: <a href="mailto:media@protonmail.ch">media@protonmail.ch</a>
                </p>
            </div><!--/.col-->
            <div class="col-md-3">
                <p>
                    For support inquiries, please visit<br>
                    <a href="https://protonmail.com/support" class="sp-before arrow-icon">
                        <i class="fa fa-arrow-right"></i> protonmail.com/support
                    </a>
                </p>
            </div><!--/.col-->
            <div class="col-md-3">
                <p>
                    For security related discussions<br>
                    <a href="mailto:security@protonmail.ch">security@protonmail.ch</a>
                </p>
            </div><!--/.col-->
        </div><!--/.cols4-->
    </div><!--/.container-->
</div>

<div id="footer">
    <div class="container">
        <div class="row">
            <div class="col-sm-2_4">
                <h4>ProtonMail</h4>
            	<ul>
                    <li><a href="https://protonmail.com/pricing">Pricing</a></li>
                    <li><a href="https://protonmail.com/security-details">Security</a></li>
                    <li><a href="https://shop.protonmail.com">Shop</a></li>
                    <li><a href="https://protonmail.com/press">Press/Media Kit</a></li>
                    <li><a href="https://protonmail.com/tor">Onion Site</a></li>
                </ul>
	    </div>
	    <div class="col-sm-2_4">
		<h4>Features</h4>
		<ul>
		    <li><a href="https://itunes.apple.com/us/app/protonmail-encrypted-email/id979659905">iOS App</a></li>
		    <li><a href="https://play.google.com/store/apps/details?id=ch.protonmail.android">Android App</a></li>
		    <li><a href="/bridge">IMAP/SMTP Bridge</a></li>
		    <li><a href="https://protonvpn.com/">ProtonVPN</a></li>
		    <li><a href="https://protonmail.com/support/knowledge-base/business/">ProtonMail Business</a></li>
    	        </ul>
	    </div>
            <div class="col-sm-2_4">
                <h4>Legal</h4>
            	<ul>
                    <li><a href="https://protonmail.com/imprint">Imprint</a></li>
                    <li><a href="https://protonmail.com/privacy-policy">Privacy Policy</a></li>
                    <li><a href="https://protonmail.com/terms-and-conditions">Terms &amp; Conditions</a></li>
                    <li><a href="https://protonmail.com/blog/transparency-report/">Transparency Report</a></li>
                    <li><a href="mailto:abuse@protonmail.ch">Report Abuse</a></li>
                </ul>
	    </div>
            <div class="col-sm-2_4">
                <h4>Company</h4>
            	<ul>
                    <li><a href="https://protonmail.com/blog/">Blog</a></li>
                    <li><a href="https://protonmail.com/about">Team</a></li>
                    <li><a href="https://protonmail.com/careers">Careers</a></li>
                    <li><a href="https://protonmail.com/support/">Support</a></li>
                    <li><a href="https://protonmail.com/donate">Donate</a></li>
                </ul>
	    </div>
            <div class="col-sm-2_4">
                <h4>Social</h4>
                <ul>
                </ul>
                <ul>
                    <li class="fb"><a href="https://facebook.com/ProtonMail"><i class="fa fa-facebook"></i> Facebook</a></li>
                    <li class="tw"><a href="https://twitter.com/ProtonMail"><i class="fa fa-twitter"></i> Twitter</a></li>
                    <li class="gplus"><a href="https://plus.google.com/+protonmail" rel="publisher"><i class="fa fa-google"></i> Find us on Google+</a></li>
                    <li class="fb-forum"><a target="_blank" href="https://protonmail.uservoice.com/"><i class="fa fa-comments"></i> Feedback Forum</a></li>
             	    <li class="fb-reddit"><a target="_blank" href="https://www.reddit.com/r/ProtonMail/"><i class="fa fa-reddit-alien"></i><span>Reddit</span></a></li>
		</ul>
            </div>
        </div>
        <p>&nbsp;</p>
        <p>&nbsp;</p>
        <p class="text-center">&copy; 2018 Proton Technologies AG. All Rights Reserved.</p>
    </div>
</div>

<script type='text/javascript' src='https://protonmail.com/blog/wp-content/plugins/anti-spam/js/anti-spam-4.4.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-content/plugins/email-subscribers/widget/es-widget.js?ver=4.9.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var es_widget_page_notices = {"es_email_notice":"Please enter email address","es_incorrect_email":"Please provide a valid email address","es_load_more":"loading...","es_ajax_error":"Cannot create XMLHTTP instance","es_success_message":"Successfully Subscribed.","es_success_notice":"Your subscription was successful! Within a few minutes, kindly check the mail in your mailbox and confirm your subscription. If you can't see the mail in your mailbox, please check your spam folder.","es_email_exists":"Email Address already exists!","es_error":"Oops.. Unexpected error occurred.","es_invalid_email":"Invalid email address","es_try_later":"Please try after some time","es_problem_request":"There was a problem with the request"};
/* ]]> */
</script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-content/plugins/email-subscribers/widget/es-widget-page.js?ver=4.9.2'></script>
<script type='text/javascript' src='https://protonmail.com/blog/wp-includes/js/wp-embed.min.js?ver=4.9.2'></script>

<script type="text/javascript" src="https://protonmail.com/js/bootstrap.min.js"></script>
<script type="text/javascript" defer>
	jQuery( function() {
		setFooter();
		jQuery(window).on('resize', setFooter);

		// fixed header
		function fixedHeader() {
   	 		if (window.pageYOffset>160) {
        			jQuery('#header').addClass('collapsed');
   			}
    			else {
        			jQuery('#header').removeClass('collapsed');
    			}
		}

		// Excerpt Height
        	function ellipsizeExcerpts() {
            		jQuery('.posts .post .excerpt').each( function() {
                		var wordArray = jQuery(this).text().split(' ');
                		if (jQuery(this)[0].scrollHeight == jQuery(this)[0].offsetHeight) {
              		      		jQuery(this)[0].innerHTML = '<p>' + wordArray.join(' ') + '</p>';
                		}
                		while(jQuery(this)[0].scrollHeight > jQuery(this)[0].offsetHeight) {
                    			wordArray.pop();
                    			jQuery(this)[0].innerHTML = '<p>' + wordArray.join(' ') + '...</p>';
                		}
           		});
       		}

		jQuery(window).on("load resize",function(e){
			 ellipsizeExcerpts();
		});

		jQuery(window).on("load resize scroll",function(e){
    			fixedHeader();
		});
	});

	function setFooter() {
		if (jQuery('body').height()<jQuery(window).height()) {
			jQuery('footer').addClass('sticky');
		}
		else {
			jQuery('footer').removeClass('sticky');
		}
	}
	jQuery('#mobileMenuToggle').on('click', function() {
		jQuery('#mobileMenu').toggle();
	});


	// Add Bootstrap classes to the theme
	jQuery('.searchform').addClass('form-inline');
	jQuery('.searchform input').addClass('form-control');
	jQuery('.searchform button').addClass('btn btn-primary');
	jQuery('.form-submit input[type="submit"]').addClass('btn btn-primary');
	jQuery('.comment-form textarea').addClass('form-control');
	jQuery('.comment-form input[type="text"], .comment-form input[type="email"], .comment-form input[type="url"]').addClass('form-control input-lg');
	jQuery('.bar li a').addClass('btn btn-ghost alt');
	jQuery('#commentform').removeClass('form-horizontal');

var dropdown = document.getElementById("cat");
function onCatChange() {
	if ( dropdown.options[dropdown.selectedIndex].value > 0 ) {
		location.href = "https://protonmail.com/blog/?cat="+dropdown.options[dropdown.selectedIndex].value;
	}
}
if (typeof dropdown !== 'undefined') {
	dropdown.onchange = onCatChange;
}

var originalFeaturedExcerptText = jQuery('.home .featured .excerpt p').eq(0).text().slice(0, -3);

function featuredExcerptSize() {

	// only for homepage
	if (!jQuery('body.home').length) { 
		return;
	}

	// we need to hide text before getting the height.
	jQuery('.home .featured .excerpt').hide();
	var featuredHeight = jQuery('.home .featured').outerHeight();
	var featuredTitleHeight = jQuery('.home .featured h3').outerHeight();
	var featuredLinkHeight = jQuery('.home .featured .btn-ghost').outerHeight();
	var padding = 160;
	var excerptHeight = featuredHeight - (featuredTitleHeight + featuredLinkHeight + padding);
	// console.log(featuredHeight, featuredTitleHeight, featuredLinkHeight, excerptHeight);
	jQuery('.home .featured .excerpt').show();
	ellipsis(excerptHeight);
}

function ellipsis(number) {
	if (number < 1) {
		jQuery('.home .featured .excerpt p').text('');
	}
	else {
		// 40 characters = 26 height roughly.
		var rows = number/26;
		var chars = rows * 40;
		var text = originalFeaturedExcerptText;
		text = text.substring(0, chars);
		jQuery('.home .featured .excerpt p').text(text + '...');
	}
}

// event listener
jQuery(window).on('load resize', function() {
	featuredExcerptSize();
});
</script>

</body>
</html>
